Jump to content


Paks's Content

There have been 5 items by Paks (Search limited from 19-January 20)


By content type

See this member's

Sort by                Order  

#339 Exception raise:

Posted by Paks on 24 January 2012 - 06:41 PM in Bugs / Issues

I just have to post to see what was i doing wrong... and by that i'm sorry... hope this will be used anytime by someone as %"·$&%"· as i am...

The error was as common as it can gets, and of course, have nothing to do with groceryCRUD

I was missing the full path in $config['base_url']...

Sorry for any inconvenience i have done... and once again, thank you so much for share your talent with this excelente peace of code



#338 Exception raise:

Posted by Paks on 24 January 2012 - 06:25 PM in Bugs / Issues

I uploaded my backend with grocery CRUD to a temp server on the internet, and setup codeigniter config vars and routes, but then, when I try to insert or update a data a exception raise

Fatal error: Uncaught exception 'Exception' with message 'On the state "insert" you must have post data' in /web/htdocs/xxx/home/demo/criteris/application/libraries/grocery_crud.php:1967
Stack trace:
#0 /web/htdocs/xxx/home/demo/criteris/application/libraries/grocery_crud.php(2679): grocery_States->getStateInfo()
#1 /web/htdocs/xxx/home/demo/criteris/application/controllers/admin.php(119): grocery_CRUD->render()
#2 [internal function]: Admin->glosari('insert')
#3 /web/htdocs/xxx/home/demo/criteris/system/core/CodeIgniter.php(359): call_user_func_array(Array, Array)
#4 /web/htdocs/xxx/home/demo/criteris/index.php(202): require_once('/web/htdocs/www...')
#5 {main}
  thrown in /web/htdocs/xxx/home/demo/criteris/application/libraries/grocery_crud.php on line 1967

I have check everything i can think off, global_xss_filtering is set to false

this is the form generated by Grocery

<form action='http://xxx/demo/criteris/admin/glosari/insert' method='post' id='crudForm' autocomplete='off' enctype="multipart/form-data">

this is the controller function
public function glosari()
   {
	  $this->grocery_crud->set_table('cri_glosari');
	  $output = $this->grocery_crud->render();
	  $this->layout_library->set_title('Glosari');
	  $this->layout_library->add_menu($this->menu_list,'Glosari');
	  $this->layout_library->view('cms_crud_view', $output, 'cms_crud_layout');
   }

I'm kind of ashamed because in my local apache server works like a charm...

Any clue on what I can be missing is more than welcome...
thanks in advance.



#238 Bug? - Call to a member function result()

Posted by Paks on 06 January 2012 - 09:39 PM in Bugs / Issues

I don't know what i did but somehow now is working like a charm.

I move everything to a single controller, and all the problems are solved! the more probable scenario is that i mess up something, so i restart with a different approach making one single controller for all the admin (so easy with groceryCRUD!) and that worked quite well... may be is what you say in your post, about to move to a function different from index, now in the index i only have the welcome screen.

Once again, thank you very much for your support, your patience and your code. I hope i can give you something back with a donation if finally i get paid with that, and in every project i use your awesome library, you absolutely deserve it.

Thanks!



#232 Bug? - Call to a member function result()

Posted by Paks on 06 January 2012 - 08:47 AM in Bugs / Issues

Hello Johnny... awesome work you are doing here

I am with you... i don't think this is a model problem

This is the code you are asking for

   public function index()
   {
	  $this->layout_library->add_menu($this->menu_list, 'Noticias');
	  $this->grocery_crud->set_table('noticias');

	  $output = $this->grocery_crud->render();


	  $this->layout_library->view('cms_crud_view', $output, 'cms_crud_layout');
   }


To make more sense of what happend, i leave here the results of the render

At first... everithing is ok

Posted Image


After a second or less... it looks likes there is another query (sorry for my ignorance if is not the case) and the content changes and now appears

Posted Image

The number line is different to 45 because in that case i just try to make some debug, with no success.

Also, i translate to spanish, when i fully tested the language i can send it to you.

Thanks!



#227 Bug? - Call to a member function result()

Posted by Paks on 06 January 2012 - 12:36 AM in Bugs / Issues

First of all... sorry by mi english... with that being said, i will try to expose my case.

I am receiving the next error




Fatal error: Call to a member function result() on a non-object in /htdocs/public/www/application/models/grocery_model.php on line 45



This happens to me only with the flexigrid theme.

I can see how the data is loaded ok, but then, at the bottom of the flexigrid theme, there is a spinner, i don't know how it works, may be is making some kind of request to the groceryCrud to validate the amount left, or loading more data... i don't know, but after i can see the data, it gets removed and the message is shown.

The line of code in grocery_model is

$results = $this->db->get($this->table_name)->result();


The most weird part is that i have another table, that work just as expected, and in my local system both are working fine.

I try to change the table in the controller that works by the one that doesn't but with no luck at all, same error. Tried to dump de data and delete the table and upload it agani... even try to wipe out the entire code and upload it agan and the error persist.

I change the theme to datatables and work fine... i think this is just personal! i need to know what is going wrong.

So please, any kind of help will be much welcome, on how to track the problem or if some one has experience the same issue. I just hope that this is not a lame error bye me.

If you need more info i will be glad to give the adress and the source.

Thanks in advances and btw... awesome work!