Jump to content


Can't Install Grocery CRUD Entreprise with PHP 8.0


  • Please log in to reply
2 replies to this topic

#1 NMed

NMed

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 February 2021 - 06:43 PM

Hello

 

When i try to install Grocery CRUD entreprise with PHP 8.0, i have this error :

 

our requirements could not be resolved to an installable set of packages.
 
  Problem 1
    - scoumbourdis/phpexcel[1.9.0, ..., 1.9.x-dev] require php ^5.4|^7.0 -> your php version (8.0.1) does not satisfy that requirement.
    - grocerycrud/enterprise 2.8.7 requires scoumbourdis/phpexcel ^1.9 -> satisfiable by scoumbourdis/phpexcel[1.9.0, 1.9.1, 1.9.x-dev].
    - Root composer.json requires grocerycrud/enterprise 2.*.* -> satisfiable by grocerycrud/enterprise[2.8.7].
 

 

scoumbourdis/phpexcel require PHP 5 or 7 but my production env are in PHP8

 

Can you help please ?



#2 web-johnny

web-johnny

    grocery CRUD Author

  • Administrators
  • 1,157 posts

Posted 20 February 2021 - 12:37 PM

Hello NMed,

 

I will have it a look and let you know. I will probably create a new version that will also support PHP 8

 

Regards

Johnny

 



Hello

 

When i try to install Grocery CRUD entreprise with PHP 8.0, i have this error :

 

our requirements could not be resolved to an installable set of packages.
 
  Problem 1
    - scoumbourdis/phpexcel[1.9.0, ..., 1.9.x-dev] require php ^5.4|^7.0 -> your php version (8.0.1) does not satisfy that requirement.
    - grocerycrud/enterprise 2.8.7 requires scoumbourdis/phpexcel ^1.9 -> satisfiable by scoumbourdis/phpexcel[1.9.0, 1.9.1, 1.9.x-dev].
    - Root composer.json requires grocerycrud/enterprise 2.*.* -> satisfiable by grocerycrud/enterprise[2.8.7].
 

 

scoumbourdis/phpexcel require PHP 5 or 7 but my production env are in PHP8

 

Can you help please ?



#3 web-johnny

web-johnny

    grocery CRUD Author

  • Administrators
  • 1,157 posts

Posted 21 February 2021 - 08:17 PM

Hello

 

When i try to install Grocery CRUD entreprise with PHP 8.0, i have this error :

 

our requirements could not be resolved to an installable set of packages.
 
  Problem 1
    - scoumbourdis/phpexcel[1.9.0, ..., 1.9.x-dev] require php ^5.4|^7.0 -> your php version (8.0.1) does not satisfy that requirement.
    - grocerycrud/enterprise 2.8.7 requires scoumbourdis/phpexcel ^1.9 -> satisfiable by scoumbourdis/phpexcel[1.9.0, 1.9.1, 1.9.x-dev].
    - Root composer.json requires grocerycrud/enterprise 2.*.* -> satisfiable by grocerycrud/enterprise[2.8.7].
 

 

scoumbourdis/phpexcel require PHP 5 or 7 but my production env are in PHP8

 

Can you help please ?

 

Hello @NMed,

 

I've updated the composer dependencies. If you try again to install it without any changes it should work. If you are still having issues, try to remove the composer.lock file and try again.

 

Regards
Johnny






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users