Jump to content


An error has occurred on uploading

error problem image upload

  • Please log in to reply
33 replies to this topic

#21 Amit Shah

Amit Shah

    grocery CRUD Master

  • Advanced Member
  • PipPipPip
  • 1,192 posts
  • LocationMumbai, India

Posted 10 July 2013 - 01:53 PM

Hello there...  here in the network panel, clicking on the url that is giving error code 500 (Internal Server Error) .. can you click on the response and grab a screen shot / copy paste the error whatever is convenient?

 

Also, if not much on error here, can you check in apache's error log file to see what is the possible error the system is throwing out? That way, it will make some sense as what is the issue and where to hit the nail...



#22 Terence Vusile Silonda

Terence Vusile Silonda

    Member

  • Members
  • PipPip
  • 11 posts

Posted 12 September 2013 - 09:12 AM

I've come to realise one of the reasons (especially on Linux servers) is the way files are named. As we all know, Linux fine names are case sensitive. For example, I had this problem because my image_moo library was not named Image_moo.



#23 Mahmoud Youssef

Mahmoud Youssef

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 24 September 2013 - 04:12 PM

I have the same problem only on windows server.

 

Any Help



#24 Bart Reis

Bart Reis

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 20 November 2013 - 05:01 PM

This error occurs because something is echoing to the screen, and then javascript functions got messed up and dont understand if the file is up or not... you can't put any echo's or any function that send chars to the screen.



#25 victor

victor

    grocery CRUD Hero

  • Advanced Member
  • PipPipPip
  • 967 posts
  • LocationMinsk

Posted 20 November 2013 - 05:03 PM

the post has been deleted (typed by mistake)



#26 clustersblue

clustersblue

    Advanced Member

  • Members
  • PipPipPip
  • 40 posts

Posted 27 November 2013 - 07:36 AM

I have the same problem seeing this pop out "An error has occurred on uploading" when I tried to upload the file (120kb).  Firebug didn't issues any error.  The response I got from the server is "{"success":false}".  My php.ini has upload_max_filesize = 20M.  I have an out of the box setup meaning I haven't change any settings yet from GC.  I wonder if my db for "upload_file" field which is varchar(500) has something to do in my case.  

 

Here is my code

function kaizen_my(){
            $crud = $this->grocery_crud;
                
                $crud->set_table('kaizen2')
                     ->set_subject('Kaizen')
                     ->set_relation('emp_number','users','username')
                     ->set_relation('waste_ID','waste','Waste')
                     ->set_relation('priority_ID','priority','priority')
                     ->set_relation_n_n('party_ID', 'interested_party', 'users', 'KaizenId', 'emp_number', 'username', null, array('users.active_ID'=>'1'))
                     ->where('kaizen2.emp_number',$this->session->userdata('emp_number'));

                $crud->columns('KaizenId','emp_number','ProposalTitle','Objectives','DateProposed','waste_ID');
                $crud->set_field_upload('upload_file','assets/uploads/files');
                $crud->add_fields('ProposalTitle','DateProposed','waste_ID','PotentialCostSavings','SavingsSchedule','Objectives','CurrentMethod','ProposedMethod','priority_ID','ImpDate','party_ID','upload_file');
                $crud->edit_fields('ProposalTitle','emp_number','DateProposed','waste_ID','PotentialCostSavings','SavingsSchedule','Objectives','CurrentMethod','ProposedMethod','priority_ID','ImpDate','party_ID','upload_file');
                $crud->required_fields('ProposalTitle','DateProposed','priority_ID','ImpDate');
                $crud->unset_delete();
                $crud->unset_texteditor('Objectives','CurrentMethod','ProposedMethod','Implementor','EvalComments','FirstComments','SecondComments','ProcessComments');
                $crud->callback_after_insert(array($this, '_kaizen_my_after_insert'));
                $crud->callback_edit_field('emp_number',array($this,'_edit_field_callback_kaizen_my'));
                
                $output = $crud->render();

                $this->load->view('main_view',$output);
        }

Thank you very much!



#27 clustersblue

clustersblue

    Advanced Member

  • Members
  • PipPipPip
  • 40 posts

Posted 27 November 2013 - 08:40 AM

Additional Fyi:

 

I tried this path 'assets/uploads/files' using CodeIgniter File Uploading Class and it works.  I was able to upload the file, thus my path doesn't have issue with write access. 



#28 Amit Shah

Amit Shah

    grocery CRUD Master

  • Advanced Member
  • PipPipPip
  • 1,192 posts
  • LocationMumbai, India

Posted 28 November 2013 - 09:22 AM

Hi clustersblue,

 

Well it dont seem that has to do anything with the field. Tell me - what is the file name (with the type) you were trying to upload? Cuz it also matters with the allowed file types.



#29 Pedro Bernal

Pedro Bernal

    Member

  • Members
  • PipPip
  • 12 posts

Posted 18 February 2014 - 04:46 PM

Hi all, I am getting the same problem, can someone help me to fix it?, I success upload in localhost but error in server hosting.. Please help....  :(



#30 Amit Shah

Amit Shah

    grocery CRUD Master

  • Advanced Member
  • PipPipPip
  • 1,192 posts
  • LocationMumbai, India

Posted 18 February 2014 - 08:56 PM

are you sure u have the permission to write on the folder.. that is what the common mistake is on hosting.. the folder might be created but the permissions are not set...



#31 Pedro Bernal

Pedro Bernal

    Member

  • Members
  • PipPip
  • 12 posts

Posted 19 February 2014 - 03:38 AM

I am not the admin of the hosting, what exactly should I ask to him, public write permission??

 

thx.



#32 Amit Shah

Amit Shah

    grocery CRUD Master

  • Advanced Member
  • PipPipPip
  • 1,192 posts
  • LocationMumbai, India

Posted 19 February 2014 - 05:16 AM

well.. u dont need to be admin .. in FTP client u connect with.. (like filezilla) - when u surf / navigate to the path where the folder resides - there u can do a right click and set the folder permissions there to 777 (check folder and subfolder / files in it too) ..

 

Happy GCing :)



#33 Pedro Bernal

Pedro Bernal

    Member

  • Members
  • PipPip
  • 12 posts

Posted 19 February 2014 - 08:21 PM

Thanks mate!

 

I already checked the permissions with Filezilla for folder and subfolder and they are in 777, what can I do now? :(



#34 clustersblue

clustersblue

    Advanced Member

  • Members
  • PipPipPip
  • 40 posts

Posted 21 February 2014 - 06:40 AM

Hi Amit Shah,

 

I was able to get it work.  It's a typo error on my db field.

 

Thanks







Also tagged with one or more of these keywords: error, problem, image, upload

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users