Jump to content


Uncaught ReferenceError: dialog_forms is not defined

dialog_forms

  • Please log in to reply
2 replies to this topic

#1 cyberale

cyberale

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 20 January 2017 - 01:17 AM

Hello,

I'm facing this error when loading the new or edit record form. Listing all records it's ok, but once on edit or new window, save and cancel buttons are not working.

This is the complete error:

Uncaught ReferenceError: dialog_forms is not defined
    at add_edit_button_listener (list.js?v1.6.1:64)
    at HTMLDocument.<anonymous> (flexigrid.js?v1.6.1:30)
    at j (jquery-1.11.1.min.js?v1.6.1:2)
    at Object.fireWith [as resolveWith] (jquery-1.11.1.min.js?v1.6.1:2)
    at Function.ready (jquery-1.11.1.min.js?v1.6.1:2)
    at HTMLDocument.J (jquery-1.11.1.min.js?v1.6.1:2)

Here are all the loaded scripts:
        <script src="<?=base_url();?>assets/grocery_crud/js/jquery-1.11.1.min.js?v1.6.1"></script>
        <script src="<?=base_url();?>assets/grocery_crud/js/jquery_plugins/jquery.noty.js?v1.6.1"></script>
        <script src="<?=base_url();?>assets/grocery_crud/js/jquery_plugins/config/jquery.noty.config.js?v1.6.1"></script>
        <script src="<?= base_url();?>assets/grocery_crud/js/common/lazyload-min.js?v1.6.1"></script>
        <script src="<?= base_url();?>assets/grocery_crud/js/common/list.js?v1.6.1"></script>
        <script src="<?=base_url();?>assets/grocery_crud/themes/flexigrid/js/cookies.js?v1.6.1"></script>
        <script src="<?=base_url();?>assets/grocery_crud/themes/flexigrid/js/flexigrid.js?v1.6.1"></script>
        <script src="<?=base_url();?>assets/grocery_crud/js/jquery_plugins/jquery.form.min.js?v1.6.1"></script>
        <script src="<?=base_url();?>assets/grocery_crud/js/jquery_plugins/jquery.numeric.min.js?v1.6.1"></script>         
        <script src="<?= base_url();?>assets/grocery_crud/themes/flexigrid/js/jquery.printElement.min.js?v1.6.1"></script>
        <script src="<?= base_url();?>assets/grocery_crud/js/jquery_plugins/jquery.fancybox-1.3.4.js?v1.6.1"></script>         
        <script src="<?= base_url();?>assets/grocery_crud/js/jquery_plugins/jquery.easing-1.3.pack.js?v1.6.1"></script>         
        <script src="<?=base_url();?>assets/grocery_crud/js/jquery_plugins/ui/jquery-ui-1.10.3.custom.min.js?v1.6.1"></script>

Just one instance of jquery is loaded. No bootstrap or any other theme is loaded.

I'm using CI 3.1.2 and Grocery Crud 1.5.7, PHP is 5.6

Any clues ?

Thanks !!

 



#2 Amit Shah

Amit Shah

    grocery CRUD Master

  • Advanced Member
  • PipPipPip
  • 1,192 posts
  • LocationMumbai, India

Posted 24 January 2017 - 06:37 AM

Well seems that some value of output html is not as expected. Can you possibly upload the code some place so one can have a look into it.. to give in some clue as what can be the possible solution?



#3 ashishagaikwad

ashishagaikwad

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 30 July 2019 - 09:10 AM

I am too facing a similar issue. Need some help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users