Jump to content


Use of $crud->columns() giving empty grids

columns set crud empty grid bug n_n relationship many-to-many relationship

  • Please log in to reply
2 replies to this topic

#1 ChristianSwier

ChristianSwier

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 11 May 2017 - 09:56 AM

The use of $crud->columns(array()) has been giving me trouble. When used it will give blank column fields in the grid. When i comment the $crud->columns line it will show all fields without a problem. I am not for sure but it looks like it is some problem with using it in combination with n_n relationship fields.



#2 Amit Shah

Amit Shah

    grocery CRUD Master

  • Advanced Member
  • PipPipPip
  • 1,192 posts
  • LocationMumbai, India

Posted 16 May 2017 - 12:13 PM

https://www.groceryc...nctions/columns

 

Please refer to the document - it clearly mentions u need to pass multiples of strings not array of strings...rectify the same and your issue will be solved

 

Happy GCing :)



#3 ChristianSwier

ChristianSwier

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 23 May 2017 - 06:24 AM

https://www.groceryc...nctions/columns

 

Please refer to the document - it clearly mentions u need to pass multiples of strings not array of strings...rectify the same and your issue will be solved

 

Happy GCing :)

Thanks for your answer, i have now fixed it with your solution. I don't understand why it uses an array in the example?







Also tagged with one or more of these keywords: columns, set, crud, empty, grid, bug, n_n relationship, many-to-many, relationship

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users