Jump to content


RMaynard

Member Since 08 Nov 2017
Offline Last Active Mar 02 2019 08:30 AM
-----

Topics I've Started

.htaccess not working correctly on new temporary Bluehost site

01 March 2019 - 05:58 PM

I have a Grocery CRUD application that runs perfectly on my old site on Bluehost, but not on the new one, also a shared  Bluehost server, although a different Linux distro (Red Hat). It works fine if I use the index.php, but not if I try to remove  it in config.php and use .htaccess, it throws 404 errors.

 

The old site is using PHP V 5.6.37, CodeIgnitor V 3.1.6 and GC V 1.6.2

 

 

The new site is using PHP V 7.0.33. CodeIgnitor V 3.1.10 and  GC V 1.6.2

 

.htaccess (The same on both sites and CodeIgnitor is installed in the same directory and path, public_html/Codeignitor)

 

<IfModule mod_rewrite.c>
    RewriteEngine On
RewriteBase /CodeIgnitor/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php/$1 [L] 
</IfModule> 
 
 
The new site also has Wordpress installed in the root of http/public.
 
The new site is also a temporary site that does not have a DNS entry pointing to it. Temp URL: http://box5307.temp.domains/~bchmoorg/
 
I have tried every iteration of htaccess and config.php I could find with no success.
 
Also in config.php all three url protocols:
 
REQUEST_URI
QUERY_STRING
PATH_INFO  

 

 
mod_rewrite is definitely working, as I ran a test and it worked as expected, but not maybe as GC/CI expects.
 
Any help in steering me in the right direction would be greatly appreciated, as I am out of ideas.