Jump to content


dhyanan73

Member Since 07 Mar 2019
Offline Last Active Oct 04 2019 08:30 PM
-----

Topics I've Started

[REQ] setDependentRelation: allow multiple dependent relations for the same relation

04 October 2019 - 05:15 PM

Hi to all,

currently setDependentRelation does not allow you to set two dependent relations with the same table (the filter table).

In the exlample below two different tables (shops and price_lists), related to orders table, in their respective dependent relations shares the same filter table (retailers, obviously also related with orders table). But only last setted dependent relationship works correctly.

@web-johnny can you solve this problem in one of the next releases, please? I think the case shown in the example below is very common so this functionality would be useful to many.


Database tables for this example:


Table "orders"
-------------------
pk_order
fk_order_retailer
fk_order_shop
fk_order_price_list
...

Table "retailers"
-------------------
pk_retailer
retailer_name
...

Table "shops"
-------------------
pk_shop
fk_shop_retailer
shop_name
...

Table "price_lists"
-------------------
pk_price_list
fk_price_list_retailer
price_list_name
...

Code in orders controller:

...
$crud->setRelation('fk_order_retailer', 'retailers', 'retailer_name');
$crud->setRelation('fk_order_shop', 'shops', 'shop_name');
$crud->setRelation('fk_order_price_list', 'price_lists', 'price_list_name');
$crud->setDependentRelation('fk_order_shop', 'fk_order_retailer', 'fk_shop_retailer'); // this currently doesn't work
$crud->setDependentRelation('fk_order_price_list', 'fk_order_retailer', 'fk_price_list_retailer');
...

 

Until the setDependentRelation function is upgraded as required, can someone suggest a work around to get the same result?

 


[BUG] Columns alias in print function

18 September 2019 - 03:32 PM

Hi developers,
in document printed by Print button, column names are raw database table column names. Is possible to print same columns alias setted for list view instead?

@web-johnny can you solve this bug in next GC version, please?

 


Issue in ver 2.7.10: web pages stops loading

03 September 2019 - 07:42 AM

Hi @web-johnny, I've upgraded GC Enterprise to ver 2.7.10 from ver 2.7.8. After that, page loading stops tryng load any kind of file in html code like favicon or css files. It seems like html page can't load any file, also files located in the same hosting. This issue happens both in local on my PC as in production on public web host. If I go back to ver 2.7.8 all works fine. Is this a bug in new version?


Close modal on save: what is this for?

15 March 2019 - 02:40 PM

Hi all,

can anyone explain what the "Close modal on save" checkbox at the bottom of the update and insertion forms is for, please?