Jump to content


Quick Search, Filter and Ordering not working on Custom Model (also on your demo)

custom model filters quick search

  • Please log in to reply
2 replies to this topic

#1 bigsio

bigsio

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 28 February 2019 - 12:25 PM

Hello, for my project I need to have a more complex query to be set on a Custom Model and, after struggling a bit, I noticed you completely loose functionality of Quick Search, Filters and Ordering on the joined columns data.

I noticed the thing shows up also in your demo "Example 3" at https://www.groceryc...te-custom-model :

in the grid at the end of the page, quick search, filters or ordering applied to the last column "Orders", that is a result from a join, don't have any effect.

 

Does exist any workaround to this? this limitation makes basically unusable GCE for my need.

thank you.

 

 

 

 



#2 w.jonker

w.jonker

    Member

  • Members
  • PipPip
  • 13 posts

Posted 15 March 2019 - 08:56 AM

Bigsio,

 

I'am using custom models, and have no problem with searching an sorting. Also in the example on https://www.groceryc...te-custom-model I have no problem searching and filtering the columns.



#3 spiritbreaker69

spiritbreaker69

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 18 March 2019 - 02:03 AM

Bigsio,

 

I'am using custom models, and have no problem with searching an sorting. Also in the example on https://www.groceryc...te-custom-model I have no problem searching and filtering the columns.

 

even in setRelation?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users